Piwik verliert seine Leichtigkeit

Gestern habe ich die neue Version von Piwik installiert: Version 1.9 — Heute habe ich ein Backup zurückgespielt.

Ein Blick in meine Zugriffe zeigte mir für heute noch keine Zugriffe an. Sollte mein Server nicht erreichbar sein? Nein, das war glücklickerweise nicht der Fall. Ein Blick in die phperrors ließ Böses erahnen:

PHP Fatal error:  Class 'Piwik_UserCountry_LocationProvider' not found in [...]/piwik/core/Tracker/Visit.php on line 609

Ein kurzer Aufruf im Browser bei geöffneter Konsole brachte die Bestätigung. Jeder Zugriff läuft auf einen fatalen Fehler und wird nicht gezählt.

Also habe ich mal gegooglet und siehe da: Ich bin nicht alleine: Mindestens ein anderer Nutzer hat auch diesen Fehler. Leider scheint es bisher aber keine Lösung zu geben. Ich gehe davon aus, dass es ein sehr spezieller Fehler ist.

Aber dennoch bin ich einigermaßen enttäuscht von Piwik. So war sonst das Update immer ganz einfach einzuspielen. Ab sofort wird man auch hier erstmal testen müssen…. Schade

Da ist der Einsatz von Google Analytics doch einfacher.

9 thoughts on “Piwik verliert seine Leichtigkeit”

  1. ich hab das gleiche Problem, bin dabei wieder auf Google Analytics umzustellen.
    Im Moment werde ich beides nebeneinander installieren.

  2. ich habe jetzt (noch einmal) den kompletten Piwik-Ordner gelöscht, dieses Mal die neue Version 1.9.1 herunter- und auf meinen Server hochgeladen und die alte config.ini.php aus dem alten config Ordner in die Neuinstallation hochgeladen. Jetzt scheint es wieder zu funktionieren, bereits länger als die 30 Sekunden beim letzten Mal…

    1. Bei mir funktionierte es zunächst auch. Dann kamen aber wieder keine Zahlen mehr – dafür aber wieder die Fehlermeldungen …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *