TextMate, rdoc and rvm

Using the Ruby-Bundle of TextMate let you ask the ruby built-in documentation of a command by hitting ctrl-h.

But I ran into some troubles when using rvm. I did’t get the manual for the method I asked for.

The problem seems to be the current version of rdoc as I found here. So I had to downgrade my rdoc gem from version 2.5.9 downto 2.4.3. But that sounds easier than it was for me. Every time I ran gem uninstall rdoc it wasn’t uninstalled. It stayed there. Even if I installed the older version and uninstalled version 2.5.9 rdoc –version brought up 2.5.9.

So I uninstalled my ruby using rvm uninstall 1.8.7 and removed also manually all gems connected with this ruby version in the following directories:

  • ~/.rvm/gemsets/ruby/1.8.7/
  • ~/.rvm/gems

Then I remove rdoc from the files

  • ~/.rvm/gemsets/global.gems
  • ~/.rvm/gemsets/default.gems

Installing ruby 1.8.7 again in rvm with the command rvm install 1.8.7 brought back the ruby version but without the latest rdoc. This one I could reinstall with gem install rdoc –version 2.4.3.

Now TextMate shows the correct help file.

Please see also the update.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *