GD-Library unter Snow Leopard

Eigentlich wollte ich ja nur bei meiner PHP Installation, die ich seinerzeit selbst auf Leopard gebaut habe, die curl Unterstützung ergänzen.

Doch leider ging das Kompilieren immer auf die Bretter. Dann dämmerte es mir: Nach dem Upgrade auf Snow Leoard muss ich alle meine lokal installierten Libraries neu kompilieren.

Nun gut, an der GD-Library habe ich aber ziemlich gekämpft. Es gab immer einen Fehler

png.h not found

Also musste ich zunächst die libz nachinstallieren und dann noch die libpng, obwohl die eigentlich bei Mac OS 10.6 mit dabei ist.

Der letzte wichtige Schritt war dann noch ein Symlink:

  sudo ln -s /usr/X11R6/include/fontconfig /usr/local/include
Damit konnte ich dann die gdlib bauen. 

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *