ldd für Mac

Ich kämpfe gerade damit, über die dmg-files sowohl subversion wie auch git zu installieren und dabei zu erreichen, dass git svn die neu installierte Version nutzt und nicht die standardmäßig unter /usr/bin/svn liegende.

Ich habe dies zunächst mit dem Setzen der PATH Variable versucht — ohne Erfolg. Dann setzte ich noch LD_LIBRARY_PATH — leider auch ohne Erfolg. Nun wollte ich checken, ob denn die passenden Libraries überhaupt gezogen werden. Also rief ich ldd svn  auf. Es gab einen Fehler.

Ich musste feststellen, dass ldd auf dem Mac otool -L heisst, und statt LD_LIBRARY_PATH muss man DYLD_LIBRARY_PATH nehmen. Allerdings führt das in meinem Fall zum Absturz…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *