„Problem extracting version of X.org“ bei der Installation der VMware Tools unter Debian etch

Nachdem ich die VMware Workstation 5.5 im Einsatz habe, wollte ich leichtsinnigerweise auch die VMware tools aktualisieren. Leider gab es die Fehlermeldung "Problem extracting version of  X.org". Ich habe daraufhin mal gegoogelt und bin auf die Einträge
http://www.vmware.com/community/thread.jspa?threadID=37355&tstart=30
und
http://www.vmware.com/community/thread.jspa?threadID=36866&tstart=0
gestoßen. Damit und mit ein wenig Tüftelei habe ich die Tools dann zum Laufen gebracht. Den ersten Beitrag konnte ich so verwenden. Beim zweiten ist anzumerken, dass zum einen bei Punkt 4 statt http://ftp.cvut.cz/vmware/vmware-any-any-update99.tar.gz nun http://ftp.cvut.cz/vmware/vmware-any-any-update101.tar.gz
herunterzuladen ist.

Aber auch beim Patchen des bin/vmware-config-tools.pl musste ich von der Anleitung unter http://heapoverflow.com/vmware-config-tools.txt abweichen. Statt

sub xserver7 {
return '/usr/bin/X';
}
musste ich
sub xserver7 {
return '/usr/bin/Xorg ';
}

ergänzen. Aber letztlich lief doch alles. Ich frage mich nur, warum es denn bei VMware.com selbst keine aktuelisierten Tools zu finden sind (bzw. ich keine gefunden habe…).

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *